openbsd 5.6 install gnome 进不了桌面

秀秀桌面并和大家分享一下自己的经验。

版主: lionux天地乾坤

回复
fengjunfan
铬 Cr
帖子: 44
注册时间: 2013-11-18 15:47

openbsd 5.6 install gnome 进不了桌面

帖子 fengjunfan » 2014-11-04 11:31

在 vmware 10 环境下面,openbsd 5.6 安装 gnome 进入不了桌面,不知是何原因……
参考了:http://undeadly.org/cgi?action=article& ... 0219085851


出现提示:
oh no! something has gone wrong.
A problem has occurred and the system can't recover.
please log out and try again.

我想在openbsd 上面安装 gnome 成功后,想安装到我的笔记本上面去,然后再慢慢去学习,请帮助

本来想插入一张错误提示图片,可是不知道如何上传图片

头像
acheng
锌 Zn
帖子: 577
注册时间: 2011-07-07 21:52

Re: openbsd 5.6 install gnome 进不了桌面

帖子 acheng » 2014-11-04 17:13

错误图片应该看不出什么东西的。还是看配置和日志。

贴一下下面这两个文件的内容:

/etc/rc.conf.local
~/.xinitrc

还有/var/log/Xorg.0.log 文件最后30行左右的内容 文件名字不是100%确定)

fengjunfan
铬 Cr
帖子: 44
注册时间: 2013-11-18 15:47

Re: openbsd 5.6 install gnome 进不了桌面

帖子 fengjunfan » 2014-11-05 9:02

# more /etc/rc.conf.local
multicast_host=YES
#pkg_scripts="${pkg_scripts} dbus_daemon avahi_daemon gdm" (因为启动桌面过程中出现错误,所以把 gdm 去掉了;重启进入 # 提示符, 键入 gdm 命令, 但还是不行)
pkg_scripts="dbus_daemon avahi_daemon "
/etc/rc.conf.local (END)
没有设置 .xinitrc ,故 root根目录下没有这个 .xinitrc



[ 423.774] (II) vmware(0): Modeline "640x480"x59.9 25.18 640 656 752 800 480 490 492 525 -hsync -vsync (31.5 kHz d)
[ 423.774] (**) vmware(0): Default mode "720x400": 35.5 MHz, 37.9 kHz, 85.0 Hz
[ 423.774] (II) vmware(0): Modeline "720x400"x85.0 35.50 720 756 828 936 400 401 404 446 -hsync +vsync (37.9 kHz d)
[ 423.774] (**) vmware(0): Default mode "640x400": 31.5 MHz, 37.9 kHz, 85.1 Hz
[ 423.774] (II) vmware(0): Modeline "640x400"x85.1 31.50 640 672 736 832 400 401 404 445 -hsync +vsync (37.9 kHz d)
[ 423.774] (**) vmware(0): Default mode "640x350": 31.5 MHz, 37.9 kHz, 85.1 Hz
[ 423.774] (II) vmware(0): Modeline "640x350"x85.1 31.50 640 672 736 832 350 382 385 445 +hsync -vsync (37.9 kHz d)
[ 423.774] (==) vmware(0): DPI set to (96, 96)
[ 423.774] (II) Loading sub module "fb"
[ 423.774] (II) LoadModule: "fb"
[ 423.783] (II) Loading /usr/X11R6/lib/modules/libfb.so
[ 423.787] (II) Module fb: vendor="X.Org Foundation"
[ 423.787] compiled for 1.15.2, module version = 1.0.0
[ 423.788] ABI class: X.Org ANSI C Emulation, version 0.4
[ 423.788] (II) Loading sub module "shadowfb"
[ 423.788] (II) LoadModule: "shadowfb"
[ 423.796] (II) Loading /usr/X11R6/lib/modules/libshadowfb.so
[ 423.809] (II) Module shadowfb: vendor="X.Org Foundation"
[ 423.809] compiled for 1.15.2, module version = 1.0.0
[ 423.809] ABI class: X.Org ANSI C Emulation, version 0.4
[ 423.809] (II) Loading sub module "ramdac"
[ 423.809] (II) LoadModule: "ramdac"
[ 423.809] (II) Module "ramdac" already built-in
[ 423.809] (II) UnloadModule: "vesa"
[ 423.809] (II) Unloading vesa
[ 423.810] (--) Depth 24 pixmap format is 32 bpp
[ 423.812] (II) vmware(0): Initialized VMWARE_CTRL extension version 0.2
[ 423.812] (II) vmware(0): Initialized VMware Xinerama extension.
[ 423.812] (II) vmware(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0
[ 424.245] (==) vmware(0): Backing store enabled
[ 424.245] (==) vmware(0): Silken mouse disabled
[ 424.268] (II) vmware(0): Initialized VMware Xv extension successfully.
[ 424.271] (==) RandR enabled
[ 424.307] (II) AIGLX: Screen 0 is not DRI2 capable
[ 424.307] (EE) AIGLX: reverting to software rendering
[ 424.415] (II) AIGLX: Loaded and initialized swrast
[ 424.415] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[ 425.089] (II) config/wscons: checking input device /dev/wskbd
[ 425.089] (II) wskbd: using layout us
[ 425.089] (II) LoadModule: "kbd"
[ 425.097] (II) Loading /usr/X11R6/lib/modules/input/kbd_drv.so
[ 425.144] (II) Module kbd: vendor="X.Org Foundation"
[ 425.144] compiled for 1.15.2, module version = 1.8.0
[ 425.144] Module class: X.Org XInput Driver
[ 425.145] ABI class: X.Org XInput driver, version 20.0
[ 425.145] (II) Using input driver 'kbd' for '/dev/wskbd'
[ 425.145] (**) /dev/wskbd: always reports core events
[ 425.145] (**) /dev/wskbd: always reports core events
[ 425.145] (**) Option "Protocol" "standard"
[ 425.145] (**) Option "XkbRules" "base"
[ 425.145] (**) Option "XkbModel" "pc105"
[ 425.145] (**) Option "XkbLayout" "us"
[ 425.146] (II) XINPUT: Adding extended input device "/dev/wskbd" (type: KEYBOARD, id 6)
[ 425.190] (II) config/wscons: checking input device /dev/wsmouse1
[ 425.190] (II) LoadModule: "ws"
[ 425.198] (II) Loading /usr/X11R6/lib/modules/input/ws_drv.so
[ 425.200] (II) Module ws: vendor="X.Org Foundation"
[ 425.200] compiled for 1.15.2, module version = 1.3.0
[ 425.201] Module class: X.Org XInput Driver
[ 425.201] ABI class: X.Org XInput driver, version 20.0
[ 425.201] (II) Using input driver 'ws' for '/dev/wsmouse1'
[ 425.201] (**) /dev/wsmouse1: always reports core events
[ 425.201] (II) ws: /dev/wsmouse1: debuglevel 0
[ 425.201] (**) Option "Device" "/dev/wsmouse1"
[ 425.201] (**) ws: /dev/wsmouse1: ZAxisMapping: buttons 4 and 5
[ 425.201] (**) ws: /dev/wsmouse1: WAxisMapping: buttons 6 and 7
[ 425.201] (**) ws: /dev/wsmouse1: associated screen: 0
[ 425.202] (**) ws: /dev/wsmouse1: device will work in raw mode
[ 425.203] (II) ws: /dev/wsmouse1: minimum x position: 0
[ 425.203] (II) ws: /dev/wsmouse1: maximum x position: 32767
[ 425.203] (II) ws: /dev/wsmouse1: minimum y position: 0
[ 425.203] (II) ws: /dev/wsmouse1: maximum y position: 32767
[ 425.203] (==) ws: /dev/wsmouse1: Buttons: 7
[ 425.241] (**) ws: /dev/wsmouse1: YAxisMapping: buttons 4 and 5
[ 425.241] (II) XINPUT: Adding extended input device "/dev/wsmouse1" (type: TOUCHSCREEN, id 7)
[ 425.242] (**) /dev/wsmouse1: (accel) keeping acceleration scheme 1
[ 425.242] (**) /dev/wsmouse1: (accel) acceleration profile 0
[ 425.242] (**) /dev/wsmouse1: (accel) acceleration factor: 2.000
[ 425.242] (**) /dev/wsmouse1: (accel) acceleration threshold: 4
[ 425.280] (II) config/wscons: checking input device /dev/wsmouse
[ 425.280] (II) Using input driver 'ws' for '/dev/wsmouse'
[ 425.280] (**) /dev/wsmouse: always reports core events
[ 425.280] (II) ws: /dev/wsmouse: debuglevel 0
[ 425.281] (**) Option "Device" "/dev/wsmouse"
[ 425.281] (**) ws: /dev/wsmouse: ZAxisMapping: buttons 4 and 5
[ 425.281] (**) ws: /dev/wsmouse: WAxisMapping: buttons 6 and 7
[ 425.281] (**) ws: /dev/wsmouse: associated screen: 0
[ 425.283] (II) ws: /dev/wsmouse: minimum x position: 0
[ 425.283] (II) ws: /dev/wsmouse: maximum x position: 1279
[ 425.283] (II) ws: /dev/wsmouse: minimum y position: 0
[ 425.283] (II) ws: /dev/wsmouse: maximum y position: 767
[ 425.283] (==) ws: /dev/wsmouse: Buttons: 7
[ 425.321] (**) ws: /dev/wsmouse: YAxisMapping: buttons 4 and 5
[ 425.321] (II) XINPUT: Adding extended input device "/dev/wsmouse" (type: MOUSE, id 8)
[ 425.323] (**) /dev/wsmouse: (accel) keeping acceleration scheme 1
[ 425.323] (**) /dev/wsmouse: (accel) acceleration profile 0
[ 425.323] (**) /dev/wsmouse: (accel) acceleration factor: 2.000
[ 425.323] (**) /dev/wsmouse: (accel) acceleration threshold: 4

头像
acheng
锌 Zn
帖子: 577
注册时间: 2011-07-07 21:52

Re: openbsd 5.6 install gnome 进不了桌面

帖子 acheng » 2014-11-05 13:39

从错误日志里面看不出什么东西,问题很可能是出在gnome3身上,它对显示性能的要求比较高。

我google了一下,发现很多人都有这个问题。我个人的感觉在Vmware上解决这个问题的机会不大。

或许你可以试试把这个虚拟机导出为ova格式(应该可以的,但我没这样做过),然后安装virtualbox虚拟机,再导入到virtualbox上。
以前在virtualbox里面,gnome3至少还能启动到fall back模式。

头像
acheng
锌 Zn
帖子: 577
注册时间: 2011-07-07 21:52

Re: openbsd 5.6 install gnome 进不了桌面

帖子 acheng » 2014-11-05 13:41

或者,如果gnome3不是必须的话,还可以试试fluxbox等其他的窗口管理器。

f5b
锆 Zr
帖子: 613
注册时间: 2011-10-22 20:43

Re: openbsd 5.6 install gnome 进不了桌面

帖子 f5b » 2014-11-09 9:49

还是建议在笔记本实体机器上进行测试,一般没有问题的

如果不想影响原有系统,在笔记本上插上移动硬盘,然后把OpenBSD系统直接安装到移动硬盘上测试也是可以的。但是性能差好远。

fengjunfan
铬 Cr
帖子: 44
注册时间: 2013-11-18 15:47

Re: openbsd 5.6 install gnome 进不了桌面

帖子 fengjunfan » 2014-11-19 18:53

f5b 写了:还是建议在笔记本实体机器上进行测试,一般没有问题的

如果不想影响原有系统,在笔记本上插上移动硬盘,然后把OpenBSD系统直接安装到移动硬盘上测试也是可以的。但是性能差好远。
在我的 hp 6930p 笔记本上安装 openbsd 5.6 i386时 ,安装成功后,令人惊讶的是竞然不能正常启动……!!,算了不装了;

又在 lenovo z460 笔记本安装成功后,可以正常启动;但还是安装gnome 不成功;算了,装个kde或xfce;

f5b
锆 Zr
帖子: 613
注册时间: 2011-10-22 20:43

Re: openbsd 5.6 install gnome 进不了桌面

帖子 f5b » 2014-11-20 9:36

fengjunfan 写了:
f5b 写了:还是建议在笔记本实体机器上进行测试,一般没有问题的

如果不想影响原有系统,在笔记本上插上移动硬盘,然后把OpenBSD系统直接安装到移动硬盘上测试也是可以的。但是性能差好远。
在我的 hp 6930p 笔记本上安装 openbsd 5.6 i386时 ,安装成功后,令人惊讶的是竞然不能正常启动……!!,算了不装了;

又在 lenovo z460 笔记本安装成功后,可以正常启动;但还是安装gnome 不成功;算了,装个kde或xfce;
安装后无法启动,能将启动过程的dmesg拍照放上来么?
大多更改bios的cpu相关选项就能启动了

netreder
钠 Na
帖子: 4
注册时间: 2015-05-03 3:02

Re: openbsd 5.6 install gnome 进不了桌面

帖子 netreder » 2015-05-06 2:30

请问你的这个问题解决了吗?我的和你的问题一样,现在不知道怎么办了。

fengjunfan
铬 Cr
帖子: 44
注册时间: 2013-11-18 15:47

Re: openbsd 5.6 install gnome 进不了桌面

帖子 fengjunfan » 2015-05-08 21:59

我用 vmware , 在 openbsd 5.7 上面安装 gonme 也还是 不成功!

回复

在线用户

正浏览此版面之用户: 没有注册用户 和 3 访客